loader gif

You Need to Patch the BlueKeep RDP Vulnerability (CVE-2019-0708)

You Need to Patch the BlueKeep RDP Vulnerability (CVE-2019-0708) (Malware and Vulnerabilities)

The vulnerability concerns Remote Desktop Services (before that called Terminal Services) that affects certain older versions of Windows.  CVE-2019-0708 could allow an attacker to execute remote code on a vulnerable machine that’s running Remote Desktop Protocol (RDP). As the vulnerability is wormable, it could spread extremely rapidly and compromise millions of systems around the world in a very short span of time.  Luckily, it seems that developing a reliable exploit to leverage this vulnerability is not a simple endeavor – so far there is no publicly available exploit code. You can find more information on applying the patch from Microsoft’s support pages.  F-Secure Radar users can identify vulnerable hosts using an Authenticated Scan. Enable Network Level Authentication Network Level Authentication (NLA) can be used to partially mitigate this vulnerability.

loader gif